Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(189)

Side by Side Diff: crypto/crypto_api.h

Issue 7491061: Rename CRYPTO_API to CRYPTO_EXPORT. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src/
Patch Set: Created 9 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch | Annotate | Revision Log
« no previous file with comments | « crypto/crypto.gyp ('k') | crypto/crypto_export.h » ('j') | no next file with comments »
Toggle Intra-line Diffs ('i') | Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
OLDNEW
(Empty)
1 // Copyright (c) 2011 The Chromium Authors. All rights reserved.
2 // Use of this source code is governed by a BSD-style license that can be
3 // found in the LICENSE file.
4
5 #ifndef CRYPTO_CRYPTO_API_H_
6 #define CRYPTO_CRYPTO_API_H_
7 #pragma once
8
9 #if defined(COMPONENT_BUILD)
10 #if defined(WIN32)
11
12 #if defined(CRYPTO_IMPLEMENTATION)
13 #define CRYPTO_API __declspec(dllexport)
14 #else
15 #define CRYPTO_API __declspec(dllimport)
16 #endif // defined(CRYPTO_IMPLEMENTATION)
17
18 #else // defined(WIN32)
19 #define CRYPTO_API __attribute__((visibility("default")))
20 #endif
21
22 #else // defined(COMPONENT_BUILD)
23 #define CRYPTO_API
24 #endif
25
26 #endif // CRYPTO_CRYPTO_API_H_
OLDNEW
« no previous file with comments | « crypto/crypto.gyp ('k') | crypto/crypto_export.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698