Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(111)

Unified Diff: Source/WebCore/ChangeLog

Issue 7065057: Merge 87802 - 2011-06-01 Shishir Agrawal <shishir@chromium.org> (Closed) Base URL: http://svn.webkit.org/repository/webkit/branches/chromium/782/
Patch Set: Created 9 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
Download patch
« no previous file with comments | « LayoutTests/fast/events/page-visibility-transition-test-expected.txt ('k') | Source/WebCore/dom/Document.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: Source/WebCore/ChangeLog
===================================================================
--- Source/WebCore/ChangeLog (revision 88002)
+++ Source/WebCore/ChangeLog (working copy)
@@ -1,3 +1,212 @@
+2011-06-01 Shishir Agrawal <shishir@chromium.org>
+
+ Reviewed by Tony Gentilcore.
+
+ Renaming the Page Visibility attributes as per the modified spec draft.
+ https://bugs.webkit.org/show_bug.cgi?id=61825
+
+ Spec draft:
+ http://dvcs.w3.org/hg/webperf/raw-file/tip/specs/PageVisibility/Overview.html
+
+ - Event needs to be webkitVisibilityChange from webkitVisibilityStateChange
+ - The attribute webkitIsVisible needs to change to webkitHidden
+
+ * dom/Document.cpp:
+ (WebCore::Document::webkitHidden):
+ (WebCore::Document::dispatchVisibilityStateChangeEvent):
+ * dom/Document.h:
+ * dom/Document.idl:
+ * dom/EventNames.h:
+
+2011-06-01 Nikolas Zimmermann <nzimmermann@rim.com>
+
+ Reviewed by Rob Buis.
+
+ Remove duplicated code in various computeReplacedLogical*() functions
+ https://bugs.webkit.org/show_bug.cgi?id=61860
+
+ Centralize this calculation in RenderBox::computeReplacedLogicalWidthRespectingMinMaxWidth:
+ int minLogicalWidth = computeReplacedLogicalWidthUsing(style()->logicalMinWidth());
+ int maxLogicalWidth = !includeMaxWidth || style()->logicalMaxWidth().isUndefined() ? logicalWidth : computeReplacedLogicalWidthUsing(style()->logicalMaxWidth());
+ return max(minLogicalWidth, min(logicalWidth, maxLogicalWidth));
+
+ Centralize this calculation in RenderBox::computeReplacedLogicalHeightRespectingMinMaxHeight:
+ int minLogicalHeight = computeReplacedLogicalHeightUsing(style()->logicalMinHeight());
+ int maxLogicalHeight = style()->logicalMaxHeight().isUndefined() ? logicalHeight : computeReplacedLogicalHeightUsing(style()->logicalMaxHeight());
+ return max(minLogicalHeight, min(logicalHeight, maxLogicalHeight));
+
+ Use the new helper methods where possible, deduplicating lots of code.
+
+ * rendering/RenderBox.cpp:
+ (WebCore::RenderBox::computeReplacedLogicalWidth):
+ (WebCore::RenderBox::computeReplacedLogicalWidthRespectingMinMaxWidth):
+ (WebCore::RenderBox::computeReplacedLogicalHeight):
+ (WebCore::RenderBox::computeReplacedLogicalHeightRespectingMinMaxHeight):
+ * rendering/RenderBox.h:
+ * rendering/RenderImage.cpp:
+ (WebCore::RenderImage::computeReplacedLogicalWidth):
+ (WebCore::RenderImage::computeReplacedLogicalHeight):
+ * rendering/RenderPart.cpp:
+ (WebCore::RenderPart::computeEmbeddedDocumentReplacedWidth):
+ (WebCore::RenderPart::computeEmbeddedDocumentReplacedHeight):
+ (WebCore::RenderPart::computeReplacedLogicalWidth):
+ (WebCore::RenderPart::computeReplacedLogicalHeight):
+ * rendering/RenderPart.h:
+ * rendering/RenderReplaced.cpp:
+ (WebCore::RenderReplaced::computeReplacedLogicalWidth):
+ (WebCore::RenderReplaced::computeReplacedLogicalHeight):
+ * rendering/svg/RenderSVGRoot.cpp:
+ (WebCore::RenderSVGRoot::computeReplacedLogicalWidth):
+ (WebCore::RenderSVGRoot::computeReplacedLogicalHeight):
+
+2011-06-01 Sheriff Bot <webkit.review.bot@gmail.com>
+
+ Unreviewed, rolling out r87788.
+ http://trac.webkit.org/changeset/87788
+ https://bugs.webkit.org/show_bug.cgi?id=61856
+
+ breaks windows chromium canary (Requested by jknotten on
+ #webkit).
+
+ * loader/archive/mhtml/MHTMLArchive.cpp:
+ * loader/archive/mhtml/MHTMLArchive.h:
+ * page/PageSerializer.cpp:
+ (WebCore::PageSerializer::serializeFrame):
+ (WebCore::PageSerializer::serializeCSSStyleSheet):
+ * platform/SharedBuffer.cpp:
+ * platform/SharedBuffer.h:
+
+2011-06-01 Joseph Pecoraro <joepeck@webkit.org>
+
+ Reviewed by Pavel Feldman.
+
+ Web Inspector: [JSC] JSLock ASSERTs Seen Under eventListenerHandlerBody
+ https://bugs.webkit.org/show_bug.cgi?id=61835
+
+ Add a JSLock call before possible allocations in jsFunction and toString.
+
+ * bindings/js/ScriptEventListener.cpp:
+ (WebCore::eventListenerHandlerBody):
+
+2011-06-01 Jay Civelli <jcivelli@chromium.org>
+
+ Reviewed by Adam Barth.
+
+ Adding MHTML generation support to MHTMLArchive.
+ https://bugs.webkit.org/show_bug.cgi?id=7169
+
+ * loader/archive/mhtml/MHTMLArchive.cpp:
+ (WebCore::generateRandomBoundary):
+ (WebCore::replaceNonPrintableCharacters):
+ (WebCore::MHTMLArchive::generateMHTMLData):
+ * loader/archive/mhtml/MHTMLArchive.h:
+ * page/PageSerializer.cpp:
+ (WebCore::PageSerializer::serializeFrame):
+ (WebCore::PageSerializer::serializeCSSStyleSheet):
+ * platform/SharedBuffer.cpp:
+ (WebCore::SharedBuffer::append):
+ * platform/SharedBuffer.h:
+
+2011-06-01 Dimitri Glazkov <dglazkov@chromium.org>
+
+ Reviewed by Kent Tamura.
+
+ Remove ShadowElement and compact remaining used bits into RenderFileUploadControl.
+ https://bugs.webkit.org/show_bug.cgi?id=61816
+
+ This is a near-mechanical move-and-rename of ShadowElement, which is now only
+ used by input[type=file]. Next step -- switch it over to new shadow DOM.
+
+ Refactoring, no change in behavior.
+
+ * CMakeLists.txt: Removed ShadowElement.cpp and ShadowElement.h.
+ * GNUmakefile.list.am: Ditto.
+ * WebCore.gypi: Ditto.
+ * WebCore.pro: Ditto.
+ * WebCore/WebCore.vcproj/WebCore.vcproj: Ditto.
+ * WebCore.xcodeproj/project.pbxproj: Ditto.
+ * WebCore/rendering/RenderingAllInOne.cpp: Ditto.
+ * rendering/RenderFileUploadControl.cpp:
+ (WebCore::UploadButton::create): Moved from ShadowElement, renamed as UploadButton.
+ (WebCore::UploadButton::detach): Ditto.
+ (WebCore::UploadButton::UploadButton): Ditto.
+ (WebCore::RenderFileUploadControl::updateFromElement): Changed to use UploadButton.
+ * rendering/RenderMeter.cpp: Removed ShadowElement.h include, which is no longer used.
+ * rendering/RenderProgress.cpp: Ditto.
+ * rendering/ShadowElement.cpp: Removed.
+ * rendering/ShadowElement.h: Removed.
+
+2011-06-01 Nikolas Zimmermann <nzimmermann@rim.com>
+
+ Reviewed by Rob Buis.
+
+ SVG fails all 3 of Hixie's CSS intrinsic sizing tests
+ https://bugs.webkit.org/show_bug.cgi?id=15473
+
+ Hixies CSS intrinsic sizing tests cover percentage sizes specified on the target SVG document as width/height attributes
+ and using width: auto / height: auto on the <object> that hosts the SVG document. Take percentage sizes of the outermost
+ SVGs width/height attributes into account when determining the intrinsic size of the <object>.
+
+ Added several other testcases demonstrating several scenarios. All tests work exactly the same in WebKit and Firefox now.
+ The *on-target-svg-absolute.xhtml tests look equal to WebKit/FF but Opera fails them, likely a relict of the different
+ interpretation of the intrinsic size of a SVG document in SVG Tiny 1.2.
+
+ Tests: svg/custom/object-sizing-height-50p-on-target-svg-absolute.xhtml
+ svg/custom/object-sizing-height-50p-on-target-svg.xhtml
+ svg/custom/object-sizing-width-50p-height-50p-on-target-svg-absolute.xhtml
+ svg/custom/object-sizing-width-50p-height-50p-on-target-svg.xhtml
+ svg/custom/object-sizing-width-50p-height-75p-on-target-svg-absolute.xhtml
+ svg/custom/object-sizing-width-50p-height-75p-on-target-svg.xhtml
+ svg/custom/object-sizing-width-50p-on-target-svg-absolute.xhtml
+ svg/custom/object-sizing-width-50p-on-target-svg.xhtml
+ svg/custom/object-sizing-width-75p-height-50p-on-target-svg-absolute.xhtml
+ svg/custom/object-sizing-width-75p-height-50p-on-target-svg.xhtml
+ svg/hixie/intrinsic/001.html
+ svg/hixie/intrinsic/002.html
+ svg/hixie/intrinsic/003.html
+
+ * rendering/RenderPart.cpp:
+ (WebCore::RenderPart::computeReplacedLogicalWidth):
+ (WebCore::RenderPart::computeReplacedLogicalHeight):
+ * rendering/svg/RenderSVGRoot.cpp:
+ (WebCore::RenderSVGRoot::computeIntrinsicRatio):
+ * rendering/svg/RenderSVGRoot.h:
+
+2011-05-31 Tonis Tiigi <tonistiigi@gmail.com>
+
+ Reviewed by Pavel Feldman.
+
+ Web Inspector: Timeline panel improvements for managing current selection
+ https://bugs.webkit.org/show_bug.cgi?id=61468
+
+ Enables X-axis dragging of the selected area.
+ Double click zoom-out.
+ Fixes slightly wrong selection area position.
+
+ * inspector/front-end/TimelineOverviewPane.js:
+ (WebInspector.TimelineOverviewPane):
+ (WebInspector.TimelineOverviewPane.prototype._dragWindow):
+ (WebInspector.TimelineOverviewPane.prototype._endWindowSelectorDragging):
+ (WebInspector.TimelineOverviewPane.prototype._resizeWindowRight):
+ (WebInspector.TimelineOverviewPane.prototype._resizeWindowMaximum):
+ (WebInspector.TimelineOverviewPane.prototype.scrollWindow):
+ (WebInspector.TimelineOverviewPane.prototype._createTimelineCategoryStatusBarCheckbox):
+ * inspector/front-end/TimelinePanel.js:
+ (WebInspector.TimelinePanel):
+
+2011-05-31 Keishi Hattori <keishi@webkit.org>
+
+ Reviewed by Kent Tamura.
+
+ Fix to enable page scroll of select element
+ https://bugs.webkit.org/show_bug.cgi?id=53628
+
+ Manual test: select-page-scroll.html
+
+ * manual-tests/select-page-scroll.html: Added.
+ * rendering/RenderListBox.cpp:
+ (WebCore::RenderListBox::computeLogicalHeight): Fix min to max.
+
2011-05-31 Yong Li <yoli@rim.com>
Reviewed by Eric Seidel.
« no previous file with comments | « LayoutTests/fast/events/page-visibility-transition-test-expected.txt ('k') | Source/WebCore/dom/Document.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698