Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(283)

Issue 6838011: adds a signal, fixes a crash, adds syslogging, and marshals disks to d-bus (Closed)

Created:
9 years, 8 months ago by rtc
Modified:
9 years, 7 months ago
Reviewers:
Ben Chan
CC:
chromium-os-reviews_chromium.org
Visibility:
Public.

Description

Bunch o' small changes in this CL 1. Fixes the makefile so it can deal with header autogeneration. Thanks Scott! 2. Fixes a crash udev-device.cc 3. Adds a simple test runner, no tests yet though. 4. Adds a signal to the d-bus API. 5. Marshals the disks type to the d-bus wire format. 6. Logs to the syslog and optionally stderr Change-Id: Ifc3e9cfb22d5dbd3cb9406a94eb41d5b2c522e52 BUG=13698 TEST=Ran platform_CrosDisksDBus on a VM. Committed: http://chrome-svn/viewvc/chromeos?view=rev&revision=a153825

Patch Set 1 #

Patch Set 2 : reverts a commom.mk change #

Total comments: 4

Patch Set 3 : addresses code review comments #

Unified diffs Side-by-side diffs Delta from patch set Stats (+78 lines, -33 lines) Patch
M .gitignore View 1 chunk +1 line, -0 lines 0 comments Download
M Makefile View 1 chunk +17 lines, -11 lines 0 comments Download
M cros-disks.conf View 1 2 1 chunk +2 lines, -8 lines 0 comments Download
M cros-disks.xml View 1 chunk +4 lines, -0 lines 0 comments Download
M disk.h View 1 chunk +1 line, -0 lines 0 comments Download
M disk.cc View 2 chunks +20 lines, -1 line 0 comments Download
A disks_testrunner.cc View 1 2 1 chunk +12 lines, -0 lines 0 comments Download
M main.cc View 4 chunks +15 lines, -12 lines 0 comments Download
M udev-device.cc View 2 chunks +6 lines, -1 line 0 comments Download

Messages

Total messages: 6 (0 generated)
rtc
9 years, 8 months ago (2011-04-13 08:54:56 UTC) #1
Ben Chan
http://codereview.chromium.org/6838011/diff/1011/cros-disks.conf File cros-disks.conf (right): http://codereview.chromium.org/6838011/diff/1011/cros-disks.conf#newcode7 cros-disks.conf:7: env CROS_DISKS_LOG_FILE=/var/log/crosdisks.log How about naming it as cros-disks.log for ...
9 years, 8 months ago (2011-04-13 15:11:47 UTC) #2
rtc
On Wed, Apr 13, 2011 at 8:11 AM, <benchan@chromium.org> wrote: > > http://codereview.chromium.org/6838011/diff/1011/cros-disks.conf > File ...
9 years, 8 months ago (2011-04-13 16:36:54 UTC) #3
Ben Chan
LGTM On 2011/04/13 16:36:54, rtc wrote: > On Wed, Apr 13, 2011 at 8:11 AM, ...
9 years, 8 months ago (2011-04-13 16:46:55 UTC) #4
rtc
On Wed, Apr 13, 2011 at 8:11 AM, <benchan@chromium.org> wrote: > > http://codereview.chromium.org/6838011/diff/1011/cros-disks.conf > File ...
9 years, 8 months ago (2011-04-13 17:59:43 UTC) #5
Ben Chan
9 years, 8 months ago (2011-04-13 18:03:04 UTC) #6
LGTM

On 2011/04/13 17:59:43, rtc wrote:
> On Wed, Apr 13, 2011 at 8:11 AM, <mailto:benchan@chromium.org> wrote:
> 
> >
> > http://codereview.chromium.org/6838011/diff/1011/cros-disks.conf
> > File cros-disks.conf (right):
> >
> > http://codereview.chromium.org/6838011/diff/1011/cros-disks.conf#newcode7
> > cros-disks.conf:7: env CROS_DISKS_LOG_FILE=/var/log/crosdisks.log
> > How about naming it as cros-disks.log for consistency?
> >
> > http://codereview.chromium.org/6838011/diff/1011/cros-disks.conf#newcode20
> > cros-disks.conf:20: chmod 0755 "${CROS_DISKS_LOG_FILE}"
> > Should the log file permission be 0644?
> >
> > And should the log directory permission be set?
> >
> 
> The new logging does away with the need to create the file in the first
> place, so I removed it from the code. I also updated the rules in the
> upstart conf file to play nicely with the boot work that Richard is trying
> to do.
> 
> PTAL
> 
> 
> >
> > http://codereview.chromium.org/6838011/diff/1011/disk.cc
> > File disk.cc (right):
> >
> > http://codereview.chromium.org/6838011/diff/1011/disk.cc#newcode41
> > disk.cc:41:
> > disk[kDeviceMountPaths].writer().append_string(mount_path().c_str());
> > According to
> >
> >
>
http://hal.freedesktop.org/docs/DeviceKit-disks/Device.html#Device:device-mou...
> > ,
> > DeviceMountPaths is a list of paths in the root namespace where the root
> > of the device is mounted. Should we pass a delimited list of paths to
> > Disk and name the variable as mount_paths/mount_path_list instead of
> > mount_path?
> >
> > http://codereview.chromium.org/6838011/diff/1011/udev-device.cc
> > File udev-device.cc (right):
> >
> > http://codereview.chromium.org/6838011/diff/1011/udev-device.cc#newcode153
> > udev-device.cc:153: }
> > My bad.  If Disk accepts a delimited list of mounted paths, we need to
> > change the code here to construct the list, or perhaps add
> > UdevDevice::GetMountedPathsString?
> >
> >
> > http://codereview.chromium.org/6838011/
> >

Powered by Google App Engine
This is Rietveld 408576698