Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(7)

Issue 628063003: Oilpan: fix (MSVC) build after r183241. (Closed)

Created:
6 years, 2 months ago by sof
Modified:
6 years, 2 months ago
CC:
blink-reviews, jamesr, dglazkov+blink, dcheng, mkwst+moarreviews_chromium.org
Base URL:
https://chromium.googlesource.com/chromium/blink.git@master
Project:
blink
Visibility:
Public.

Description

Oilpan: fix (MSVC) build after r183241. Rename WebFrame::isAlive(Visitor*, WebFrame*) to isFrameAlive(). Using isAlive() is problematic wrt IsGarbageCollectedMixin<T>, which syntactically probes for isAlive(). (MSVC is more eager about template instantiation and the probing for the private WebFrame::isAlive() method is disallowed.) R=haraken,tkent BUG= NOTRY=true Committed: https://src.chromium.org/viewvc/blink?view=rev&revision=183247

Patch Set 1 #

Unified diffs Side-by-side diffs Delta from patch set Stats (+3 lines, -3 lines) Patch
M Source/web/WebFrame.cpp View 2 chunks +2 lines, -2 lines 0 comments Download
M public/web/WebFrame.h View 1 chunk +1 line, -1 line 0 comments Download

Messages

Total messages: 12 (3 generated)
sof
Please take a look.
6 years, 2 months ago (2014-10-06 07:02:56 UTC) #2
haraken
LGTM
6 years, 2 months ago (2014-10-06 07:05:08 UTC) #3
tkent
lgtm. We may rename GarbageCollectedIMixin::isAlive instead. It's a very generic name.
6 years, 2 months ago (2014-10-06 07:06:40 UTC) #4
tkent
6 years, 2 months ago (2014-10-06 07:06:47 UTC) #6
haraken
> We may rename GarbageCollectedIMixin::isAlive instead. It's a very generic > name. Agreed.
6 years, 2 months ago (2014-10-06 07:09:38 UTC) #7
sof
On 2014/10/06 07:06:40, tkent wrote: > lgtm. > > We may rename GarbageCollectedIMixin::isAlive instead. It's ...
6 years, 2 months ago (2014-10-06 07:14:32 UTC) #8
commit-bot: I haz the power
CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/patch-status/628063003/1
6 years, 2 months ago (2014-10-06 07:20:28 UTC) #10
commit-bot: I haz the power
Committed patchset #1 (id:1) as 183247
6 years, 2 months ago (2014-10-06 07:21:05 UTC) #11
sof
6 years, 2 months ago (2014-10-06 08:46:29 UTC) #12
Message was sent while issue was closed.
On 2014/10/06 07:14:32, sof wrote:
> On 2014/10/06 07:06:40, tkent wrote:
> > lgtm.
> > 
> > We may rename GarbageCollectedIMixin::isAlive instead.  It's a very generic
> > name.
> 
> Yes, that isAlive() is only used internally (afaik) so we have some extra
> degrees of freedom.

Should we want to do that, https://codereview.chromium.org/633463002/

[Renaming this particular WebFrame helper makes sense regardless, i think.
Naming now being similar to traceFrame().]

Powered by Google App Engine
This is Rietveld 408576698