Index: src/hydrogen-load-elimination.cc |
diff --git a/src/hydrogen-load-elimination.cc b/src/hydrogen-load-elimination.cc |
index 3337188f9a46387591b51268453c2023dd291f0f..a1f6f5d27cfbd9d76d35033e9d49a5b9fd1a2a7c 100644 |
--- a/src/hydrogen-load-elimination.cc |
+++ b/src/hydrogen-load-elimination.cc |
@@ -273,7 +273,10 @@ class HLoadEliminationTable : public ZoneObject { |
// Kill the next field in case of overlap. |
int size = kPointerSize; |
- if (access.representation().IsByte()) size = 1; |
+ if (access.representation().IsInteger8() || |
+ access.representation().IsUInteger8()) size = 1; |
Yang
2013/11/08 08:45:59
I favor adding brackets for readability.
Sven Panne
2013/11/08 09:09:30
I would favor something actually OO-like: Adding a
danno
2013/11/08 10:49:12
Done.
danno
2013/11/08 10:49:12
Done.
|
+ if (access.representation().IsInteger16() || |
+ access.representation().IsUInteger16()) size = 2; |
else if (access.representation().IsInteger32()) size = 4; |
int next_field = (offset + size - 1) / kPointerSize; |
if (next_field != field) KillFieldInternal(object, next_field, NULL); |