Chromium Code Reviews
Help | Chromium Project | Sign in
(67)

Issue 5699003: Use correct calling convention for API calls on MinGW (Closed)

Can't Edit
Can't Publish+Mail
Start Review
Created:
4 years, 7 months ago by Vyacheslav Egorov
Modified:
4 years, 2 months ago
Reviewers:
Erik Corry, antonm
CC:
v8-dev
Visibility:
Public.

Description

Use correct calling convention for API calls on MinGW BUG=v8:950 Committed: http://code.google.com/p/v8/source/detail?r=5958

Patch Set 1 #

Patch Set 2 : rename flag #

Total comments: 4
Unified diffs Side-by-side diffs Delta from patch set Stats (+13 lines, -10 lines) Patch
M src/ia32/macro-assembler-ia32.cc View 1 2 chunks +13 lines, -10 lines 4 comments Download
Trybot results:
Commit: CQ not working?

Messages

Total messages: 4 (0 generated)
Vyacheslav Egorov
4 years, 7 months ago (2010-12-09 19:25:08 UTC) #1
antonm
LGTM Sorry for popping up, I just happened to work on this part of the ...
4 years, 7 months ago (2010-12-09 19:35:34 UTC) #2
Erik Corry
lgtm http://codereview.chromium.org/5699003/diff/2001/src/ia32/macro-assembler-ia32.cc File src/ia32/macro-assembler-ia32.cc (right): http://codereview.chromium.org/5699003/diff/2001/src/ia32/macro-assembler-ia32.cc#newcode1225 src/ia32/macro-assembler-ia32.cc:1225: #if defined(USING_BSD_ABI) || defined(__MINGW32__) On 2010/12/09 19:35:34, antonm ...
4 years, 7 months ago (2010-12-10 11:35:10 UTC) #3
Vyacheslav Egorov
4 years, 7 months ago (2010-12-10 11:40:04 UTC) #4
http://codereview.chromium.org/5699003/diff/2001/src/ia32/macro-assembler-ia3...
File src/ia32/macro-assembler-ia32.cc (right):

http://codereview.chromium.org/5699003/diff/2001/src/ia32/macro-assembler-ia3...
src/ia32/macro-assembler-ia32.cc:1225: #if defined(USING_BSD_ABI) ||
defined(__MINGW32__)
On 2010/12/10 11:35:20, Erik Corry wrote:
> On 2010/12/09 19:35:34, antonm wrote:
> > I'd rather moved defined(__MINGW32__) into src/globals.h where USING_BSD_ABI
> is
> > defined
>  I agree with Anton.

I committed as is.
I do not think that defining USING_BSD_ABI for __MINGW32__ is correct thing.
(name is misleading).
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld 5fa3ca5