Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(305)

Unified Diff: components/rappor/proto/rappor_metric.proto

Issue 49753002: RAPPOR implementation (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: Created 7 years ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: components/rappor/proto/rappor_metric.proto
diff --git a/chrome/common/metrics/proto/user_action_event.proto b/components/rappor/proto/rappor_metric.proto
similarity index 65%
copy from chrome/common/metrics/proto/user_action_event.proto
copy to components/rappor/proto/rappor_metric.proto
index ff688b67b1b7a7ac9fe3c4c63e65c29acf83fe6b..e80cad21780f75e22e53fe8376d694f3d079b6f5 100644
--- a/chrome/common/metrics/proto/user_action_event.proto
+++ b/components/rappor/proto/rappor_metric.proto
@@ -9,13 +9,16 @@ syntax = "proto2";
option optimize_for = LITE_RUNTIME;
-package metrics;
+package rappor;
// Next tag: 3
jwd 2013/12/17 23:00:25 Update next tag, maybe drop it.
Steven Holte 2013/12/18 23:38:49 Done.
-message UserActionEventProto {
- // The name of the action, hashed.
+message RapporMetricsProto {
+message RapporMetricProto {
jwd 2013/12/17 23:00:25 indent inner message. Do these have to be named *
Steven Holte 2013/12/18 02:06:12 I had included it in the name because UserActionEv
+ // The name of the metric, hashed.
optional fixed64 name_hash = 1;
- // The timestamp for the event, in seconds since the epoch.
- optional int64 time = 2;
+ // The reported bits for the event
+ optional bytes bits = 2;
+}
+ repeated RapporMetricProto rappor = 1;
}

Powered by Google App Engine
This is Rietveld 408576698