Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(217)

Side by Side Diff: Source/core/dom/TouchList.h

Issue 483343002: Rename TouchList::create() to TouchList::adopt() for clarity (Closed) Base URL: svn://svn.chromium.org/blink/trunk
Patch Set: Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch | Annotate | Revision Log
« no previous file with comments | « Source/core/dom/Document.cpp ('k') | no next file » | no next file with comments »
Toggle Intra-line Diffs ('i') | Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
OLDNEW
1 /* 1 /*
2 * Copyright 2008, The Android Open Source Project 2 * Copyright 2008, The Android Open Source Project
3 * 3 *
4 * Redistribution and use in source and binary forms, with or without 4 * Redistribution and use in source and binary forms, with or without
5 * modification, are permitted provided that the following conditions 5 * modification, are permitted provided that the following conditions
6 * are met: 6 * are met:
7 * * Redistributions of source code must retain the above copyright 7 * * Redistributions of source code must retain the above copyright
8 * notice, this list of conditions and the following disclaimer. 8 * notice, this list of conditions and the following disclaimer.
9 * * Redistributions in binary form must reproduce the above copyright 9 * * Redistributions in binary form must reproduce the above copyright
10 * notice, this list of conditions and the following disclaimer in the 10 * notice, this list of conditions and the following disclaimer in the
(...skipping 23 matching lines...) Expand all
34 34
35 namespace blink { 35 namespace blink {
36 36
37 class TouchList FINAL : public RefCountedWillBeGarbageCollected<TouchList>, publ ic ScriptWrappable { 37 class TouchList FINAL : public RefCountedWillBeGarbageCollected<TouchList>, publ ic ScriptWrappable {
38 public: 38 public:
39 static PassRefPtrWillBeRawPtr<TouchList> create() 39 static PassRefPtrWillBeRawPtr<TouchList> create()
40 { 40 {
41 return adoptRefWillBeNoop(new TouchList); 41 return adoptRefWillBeNoop(new TouchList);
42 } 42 }
43 43
44 static PassRefPtrWillBeRawPtr<TouchList> create(WillBeHeapVector<RefPtrWillB eMember<Touch> >& touches) 44 static PassRefPtrWillBeRawPtr<TouchList> adopt(WillBeHeapVector<RefPtrWillBe Member<Touch> >& touches)
45 { 45 {
46 return adoptRefWillBeNoop(new TouchList(touches)); 46 return adoptRefWillBeNoop(new TouchList(touches));
47 } 47 }
48 48
49 unsigned length() const { return m_values.size(); } 49 unsigned length() const { return m_values.size(); }
50 50
51 Touch* item(unsigned); 51 Touch* item(unsigned);
52 const Touch* item(unsigned) const; 52 const Touch* item(unsigned) const;
53 53
54 void append(const PassRefPtrWillBeRawPtr<Touch> touch) { m_values.append(tou ch); } 54 void append(const PassRefPtrWillBeRawPtr<Touch> touch) { m_values.append(tou ch); }
(...skipping 11 matching lines...) Expand all
66 m_values.swap(touches); 66 m_values.swap(touches);
67 ScriptWrappable::init(this); 67 ScriptWrappable::init(this);
68 } 68 }
69 69
70 WillBeHeapVector<RefPtrWillBeMember<Touch> > m_values; 70 WillBeHeapVector<RefPtrWillBeMember<Touch> > m_values;
71 }; 71 };
72 72
73 } // namespace blink 73 } // namespace blink
74 74
75 #endif /* TouchList_h */ 75 #endif /* TouchList_h */
OLDNEW
« no previous file with comments | « Source/core/dom/Document.cpp ('k') | no next file » | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698