Chromium Code Reviews
Help | Chromium Project | Sign in
(46)

Issue 4537001: Update with new test suite, with shorter test data set. (Closed)

Can't Edit
Can't Publish+Mail
Start Review
Created:
3 years, 5 months ago by lzheng
Modified:
2 years, 11 months ago
Reviewers:
shess
CC:
chromium-reviews_chromium.org, ben+cc_chromium.org, gcasto
Visibility:
Public.

Description

Update with new test suite, with shorter test data set.
BUG=47318
TEST=safe_browsing_test green on trybots

Committed: http://src.chromium.org/viewvc/chrome?view=rev&revision=66196

Patch Set 1 : '' #

Patch Set 2 : '' #

Patch Set 3 : sync #

Unified diffs Side-by-side diffs Delta from patch set Stats (+10 lines, -18 lines) Lint Patch
M DEPS View 1 2 1 chunk +1 line, -1 line 0 comments 0 errors Download
M chrome/browser/safe_browsing/safe_browsing_test.cc View 1 2 3 chunks +9 lines, -17 lines 0 comments 0 errors Download
Commit:

Messages

Total messages: 5
lzheng
With the r105 of safebrowsing test server, the test data is smaller, at the same ...
3 years, 5 months ago #1
shess
LGTM.
3 years, 5 months ago #2
lzheng
Scott: I disabled ipv6 since when using 'localhost' on windows, ipv6 will try [::1] first ...
3 years, 5 months ago #3
shess
LGTM. You should bug someone who knows Windows better (maybe eroman) and see if this ...
3 years, 5 months ago #4
lzheng
3 years, 5 months ago #5
Eric helped me located this problem. He is fine to have the flag here.

Thanks!

Lei

On 2010/11/13 14:44:57, shess wrote:
> LGTM.
> 
> You should bug someone who knows Windows better (maybe eroman) and see
> if this is a generally-interesting change to make for the test suite.
> Exercising the ipv6 code is useful, but exercising the same paths
> hundreds/thousands of times is redundant, especially if it adds
> timeouts.
> 
> -scott
> 
> 
> On Fri, Nov 12, 2010 at 10:34 PM,  <mailto:lzheng@chromium.org> wrote:
> > Scott:
> >
> > I disabled ipv6 since when using 'localhost' on windows, ipv6 will try [::1]
> > first and makes request slow. After ipv6 is disabled, the test takes 11secs
> > instead of 34 secs on windows. The test runs pretty stable now on trybots.
> > Let me know if this is okay with you. Otherwise, I will commit it after
> > another
> > sync.
> >
> > On 2010/11/09 22:19:15, shess wrote:
> >>
> >> LGTM.
> >
> >
> >
> > http://codereview.chromium.org/4537001/
> >
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld 1280:2d3e6564b7b6