Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(25)

Unified Diff: src/base/platform/mutex.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/base/platform/elapsed-timer.h ('k') | src/base/platform/mutex.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/base/platform/mutex.h
diff --git a/src/base/platform/mutex.h b/src/base/platform/mutex.h
index 256b1cee4f88dd1ae1ea8dd7cc1f2aa526823d9f..2f8c07d89e58b0358caa5598b1f1964ba3fc767d 100644
--- a/src/base/platform/mutex.h
+++ b/src/base/platform/mutex.h
@@ -74,14 +74,14 @@ class Mutex V8_FINAL {
V8_INLINE void AssertHeldAndUnmark() {
#ifdef DEBUG
- ASSERT_EQ(1, level_);
+ DCHECK_EQ(1, level_);
level_--;
#endif
}
V8_INLINE void AssertUnheldAndMark() {
#ifdef DEBUG
- ASSERT_EQ(0, level_);
+ DCHECK_EQ(0, level_);
level_++;
#endif
}
« no previous file with comments | « src/base/platform/elapsed-timer.h ('k') | src/base/platform/mutex.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698