Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(710)

Unified Diff: src/compiler/scheduler.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/compiler/schedule.h ('k') | src/compiler/scheduler.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/compiler/scheduler.h
diff --git a/src/compiler/scheduler.h b/src/compiler/scheduler.h
index 18e8f92769aad9bc0f129dcdaab8e0fb9f1da812..843b071a9832bb18320ea309e73990a9dc84b05c 100644
--- a/src/compiler/scheduler.h
+++ b/src/compiler/scheduler.h
@@ -43,9 +43,9 @@ class Scheduler {
IntVector schedule_early_rpo_index_;
int GetRPONumber(BasicBlock* block) {
- ASSERT(block->rpo_number_ >= 0 &&
+ DCHECK(block->rpo_number_ >= 0 &&
block->rpo_number_ < static_cast<int>(schedule_->rpo_order_.size()));
- ASSERT(schedule_->rpo_order_[block->rpo_number_] == block);
+ DCHECK(schedule_->rpo_order_[block->rpo_number_] == block);
return block->rpo_number_;
}
« no previous file with comments | « src/compiler/schedule.h ('k') | src/compiler/scheduler.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698