Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(197)

Unified Diff: src/factory.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/extensions/trigger-failure-extension.cc ('k') | src/factory.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/factory.h
diff --git a/src/factory.h b/src/factory.h
index 408b6573c4204e071b4483520afc96b411cd275a..f09d24719c7702320892e629e503c272587fc6fb 100644
--- a/src/factory.h
+++ b/src/factory.h
@@ -110,7 +110,7 @@ class Factory V8_FINAL {
inline Handle<String> NewStringFromStaticAscii(
const char (&str)[N],
PretenureFlag pretenure = NOT_TENURED) {
- ASSERT(N == StrLength(str) + 1);
+ DCHECK(N == StrLength(str) + 1);
return NewStringFromOneByte(
STATIC_ASCII_VECTOR(str), pretenure).ToHandleChecked();
}
« no previous file with comments | « src/extensions/trigger-failure-extension.cc ('k') | src/factory.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698