Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(542)

Unified Diff: src/hydrogen-redundant-phi.cc

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/hydrogen-range-analysis.cc ('k') | src/hydrogen-removable-simulates.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/hydrogen-redundant-phi.cc
diff --git a/src/hydrogen-redundant-phi.cc b/src/hydrogen-redundant-phi.cc
index 67d534eda010ef4aab49a2fe4f470f225d0ef382..0b9b0aaf1dceb52e6dee38d3b15f5240c72fd81a 100644
--- a/src/hydrogen-redundant-phi.cc
+++ b/src/hydrogen-redundant-phi.cc
@@ -25,7 +25,7 @@ void HRedundantPhiEliminationPhase::Run() {
// Make sure that we *really* removed all redundant phis.
for (int i = 0; i < blocks->length(); ++i) {
for (int j = 0; j < blocks->at(i)->phis()->length(); j++) {
- ASSERT(blocks->at(i)->phis()->at(j)->GetRedundantReplacement() == NULL);
+ DCHECK(blocks->at(i)->phis()->at(j)->GetRedundantReplacement() == NULL);
}
}
#endif
« no previous file with comments | « src/hydrogen-range-analysis.cc ('k') | src/hydrogen-removable-simulates.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698