Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(409)

Unified Diff: src/hydrogen-mark-deoptimize.cc

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/hydrogen-load-elimination.cc ('k') | src/hydrogen-osr.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/hydrogen-mark-deoptimize.cc
diff --git a/src/hydrogen-mark-deoptimize.cc b/src/hydrogen-mark-deoptimize.cc
index 998be073e225d4926d8b030a71c180231650be52..47642e45cdda9c89b19ec732db26aa5bafd7d207 100644
--- a/src/hydrogen-mark-deoptimize.cc
+++ b/src/hydrogen-mark-deoptimize.cc
@@ -20,8 +20,8 @@ void HMarkDeoptimizeOnUndefinedPhase::Run() {
void HMarkDeoptimizeOnUndefinedPhase::ProcessPhi(HPhi* phi) {
- ASSERT(phi->CheckFlag(HValue::kAllowUndefinedAsNaN));
- ASSERT(worklist_.is_empty());
+ DCHECK(phi->CheckFlag(HValue::kAllowUndefinedAsNaN));
+ DCHECK(worklist_.is_empty());
// Push the phi onto the worklist
phi->ClearFlag(HValue::kAllowUndefinedAsNaN);
« no previous file with comments | « src/hydrogen-load-elimination.cc ('k') | src/hydrogen-osr.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698