Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(422)

Unified Diff: src/hydrogen-types.cc

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/hydrogen-representation-changes.cc ('k') | src/hydrogen-uint32-analysis.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/hydrogen-types.cc
diff --git a/src/hydrogen-types.cc b/src/hydrogen-types.cc
index 9ce9e3f1f1177cba5d10d19f69a1b7a896e8be96..c83ff3cf89037ab184bee97819e32d08c347b82a 100644
--- a/src/hydrogen-types.cc
+++ b/src/hydrogen-types.cc
@@ -48,7 +48,7 @@ HType HType::FromValue(Handle<Object> value) {
if (value->IsUndefined()) return HType::Undefined();
if (value->IsJSArray()) return HType::JSArray();
if (value->IsJSObject()) return HType::JSObject();
- ASSERT(value->IsHeapObject());
+ DCHECK(value->IsHeapObject());
return HType::HeapObject();
}
« no previous file with comments | « src/hydrogen-representation-changes.cc ('k') | src/hydrogen-uint32-analysis.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698