Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(479)

Unified Diff: src/diy-fp.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/disassembler.cc ('k') | src/double.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/diy-fp.h
diff --git a/src/diy-fp.h b/src/diy-fp.h
index f8f2673c4107010f617a304f3dc6321af28373eb..31f787265eab8d818cc926d09f4f4f7d4900fd11 100644
--- a/src/diy-fp.h
+++ b/src/diy-fp.h
@@ -25,8 +25,8 @@ class DiyFp {
// must be bigger than the significand of other.
// The result will not be normalized.
void Subtract(const DiyFp& other) {
- ASSERT(e_ == other.e_);
- ASSERT(f_ >= other.f_);
+ DCHECK(e_ == other.e_);
+ DCHECK(f_ >= other.f_);
f_ -= other.f_;
}
@@ -51,7 +51,7 @@ class DiyFp {
}
void Normalize() {
- ASSERT(f_ != 0);
+ DCHECK(f_ != 0);
uint64_t f = f_;
int e = e_;
« no previous file with comments | « src/disassembler.cc ('k') | src/double.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698