Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(148)

Unified Diff: src/list.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/libplatform/task-queue.cc ('k') | src/list-inl.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/list.h
diff --git a/src/list.h b/src/list.h
index 88171792178924064850eed79b1d4dc9a4ff6a68..ea5fd1e0cac37a0840a7e3f1eb4dea8f6acdff53 100644
--- a/src/list.h
+++ b/src/list.h
@@ -62,8 +62,8 @@ class List {
// not safe to use after operations that can change the list's
// backing store (e.g. Add).
inline T& operator[](int i) const {
- ASSERT(0 <= i);
- SLOW_ASSERT(i < length_);
+ DCHECK(0 <= i);
+ SLOW_DCHECK(i < length_);
return data_[i];
}
inline T& at(int i) const { return operator[](i); }
« no previous file with comments | « src/libplatform/task-queue.cc ('k') | src/list-inl.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698