Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(209)

Unified Diff: src/heap-snapshot-generator-inl.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/heap-snapshot-generator.cc ('k') | src/hydrogen.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/heap-snapshot-generator-inl.h
diff --git a/src/heap-snapshot-generator-inl.h b/src/heap-snapshot-generator-inl.h
index b4021ecafb44d23ee21755114fa74051fb038cc6..f7d87aa31b263fb7711c60388d7192ac9051ea3f 100644
--- a/src/heap-snapshot-generator-inl.h
+++ b/src/heap-snapshot-generator-inl.h
@@ -35,8 +35,8 @@ int HeapEntry::set_children_index(int index) {
HeapGraphEdge** HeapEntry::children_arr() {
- ASSERT(children_index_ >= 0);
- SLOW_ASSERT(children_index_ < snapshot_->children().length() ||
+ DCHECK(children_index_ >= 0);
+ SLOW_DCHECK(children_index_ < snapshot_->children().length() ||
(children_index_ == snapshot_->children().length() &&
children_count_ == 0));
return &snapshot_->children().first() + children_index_;
« no previous file with comments | « src/heap-snapshot-generator.cc ('k') | src/hydrogen.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698