Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(274)

Unified Diff: src/func-name-inferrer.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/full-codegen.cc ('k') | src/gc-tracer.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/func-name-inferrer.h
diff --git a/src/func-name-inferrer.h b/src/func-name-inferrer.h
index 43ef761fea95a038b2106fdd99373c0bfa964e42..8b077f9d8cf6b4c0ebee72d677378d965bd5c951 100644
--- a/src/func-name-inferrer.h
+++ b/src/func-name-inferrer.h
@@ -61,7 +61,7 @@ class FuncNameInferrer : public ZoneObject {
// Infers a function name and leaves names collection state.
void Infer() {
- ASSERT(IsOpen());
+ DCHECK(IsOpen());
if (!funcs_to_infer_.is_empty()) {
InferFunctionsNames();
}
@@ -69,7 +69,7 @@ class FuncNameInferrer : public ZoneObject {
// Leaves names collection state.
void Leave() {
- ASSERT(IsOpen());
+ DCHECK(IsOpen());
names_stack_.Rewind(entries_stack_.RemoveLast());
if (entries_stack_.is_empty())
funcs_to_infer_.Clear();
« no previous file with comments | « src/full-codegen.cc ('k') | src/gc-tracer.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698