Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1502)

Unified Diff: src/code.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/checks.h ('k') | src/code-stubs.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/code.h
diff --git a/src/code.h b/src/code.h
index 2b821c6512de72ad70457c2b002b397d972d1a30..d0a5fec61ffc6a70494a1520022313f6121f2801 100644
--- a/src/code.h
+++ b/src/code.h
@@ -30,11 +30,11 @@ class ParameterCount BASE_EMBEDDED {
bool is_immediate() const { return !is_reg(); }
Register reg() const {
- ASSERT(is_reg());
+ DCHECK(is_reg());
return reg_;
}
int immediate() const {
- ASSERT(is_immediate());
+ DCHECK(is_immediate());
return immediate_;
}
« no previous file with comments | « src/checks.h ('k') | src/code-stubs.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698