Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(35)

Unified Diff: src/snapshot-source-sink.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/snapshot-external.cc ('k') | src/snapshot-source-sink.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/snapshot-source-sink.h
diff --git a/src/snapshot-source-sink.h b/src/snapshot-source-sink.h
index f98b5d0a4e0283ab1d717ecde0ac4227c6bf66f2..bda6455e8b9b7d531e380e14b9cb6755db4b27d6 100644
--- a/src/snapshot-source-sink.h
+++ b/src/snapshot-source-sink.h
@@ -25,7 +25,7 @@ class SnapshotByteSource V8_FINAL {
bool HasMore() { return position_ < length_; }
int Get() {
- ASSERT(position_ < length_);
+ DCHECK(position_ < length_);
return data_[position_++];
}
@@ -73,7 +73,7 @@ class SnapshotByteSink {
virtual ~SnapshotByteSink() { }
virtual void Put(byte b, const char* description) = 0;
virtual void PutSection(int b, const char* description) {
- ASSERT_LE(b, kMaxUInt8);
+ DCHECK_LE(b, kMaxUInt8);
Put(static_cast<byte>(b), description);
}
void PutInt(uintptr_t integer, const char* description);
« no previous file with comments | « src/snapshot-external.cc ('k') | src/snapshot-source-sink.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698