Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(125)

Unified Diff: src/compiler/linkage.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/compiler/js-typed-lowering.cc ('k') | src/compiler/linkage.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/compiler/linkage.h
diff --git a/src/compiler/linkage.h b/src/compiler/linkage.h
index 9d9c50876aa1204ca1aff307d3b68540da0faf62..310a87a9ca91f67eaab83ad7b8cbc331e0a62a9e 100644
--- a/src/compiler/linkage.h
+++ b/src/compiler/linkage.h
@@ -79,12 +79,12 @@ class CallDescriptor : public ZoneObject {
}
LinkageLocation GetReturnLocation(int index) {
- ASSERT(index < return_count_);
+ DCHECK(index < return_count_);
return locations_[0 + index]; // return locations start at 0.
}
LinkageLocation GetInputLocation(int index) {
- ASSERT(index < input_count_ + 1); // input_count + 1 is the context.
+ DCHECK(index < input_count_ + 1); // input_count + 1 is the context.
return locations_[return_count_ + index]; // inputs start after returns.
}
« no previous file with comments | « src/compiler/js-typed-lowering.cc ('k') | src/compiler/linkage.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698