Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(229)

Unified Diff: src/smart-pointers.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/small-pointer-list.h ('k') | src/snapshot-external.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/smart-pointers.h
diff --git a/src/smart-pointers.h b/src/smart-pointers.h
index db2206a32f5deb35a3cf26ca16caab20cee99a86..c4bbd0b45e57155f240f2e30d1152d172e0c68d4 100644
--- a/src/smart-pointers.h
+++ b/src/smart-pointers.h
@@ -56,7 +56,7 @@ class SmartPointerBase {
}
void Reset(T* new_value) {
- ASSERT(p_ == NULL || p_ != new_value);
+ DCHECK(p_ == NULL || p_ != new_value);
if (p_) Deallocator::Delete(p_);
p_ = new_value;
}
@@ -66,7 +66,7 @@ class SmartPointerBase {
// double freeing.
SmartPointerBase<Deallocator, T>& operator=(
const SmartPointerBase<Deallocator, T>& rhs) {
- ASSERT(is_empty());
+ DCHECK(is_empty());
T* tmp = rhs.p_; // swap to handle self-assignment
const_cast<SmartPointerBase<Deallocator, T>&>(rhs).p_ = NULL;
p_ = tmp;
« no previous file with comments | « src/small-pointer-list.h ('k') | src/snapshot-external.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698