Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1422)

Unified Diff: src/base/safe_conversions_impl.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/base/platform/time.cc ('k') | src/base/utils/random-number-generator.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/base/safe_conversions_impl.h
diff --git a/src/base/safe_conversions_impl.h b/src/base/safe_conversions_impl.h
index 0a9ed9b71978eb55690bb403029988a603958db3..90c8e19353d71150b29da44cd90b717289f75032 100644
--- a/src/base/safe_conversions_impl.h
+++ b/src/base/safe_conversions_impl.h
@@ -99,7 +99,7 @@ enum RangeConstraint {
// Helper function for coercing an int back to a RangeContraint.
inline RangeConstraint GetRangeConstraint(int integer_range_constraint) {
- ASSERT(integer_range_constraint >= RANGE_VALID &&
+ DCHECK(integer_range_constraint >= RANGE_VALID &&
integer_range_constraint <= RANGE_INVALID);
return static_cast<RangeConstraint>(integer_range_constraint);
}
« no previous file with comments | « src/base/platform/time.cc ('k') | src/base/utils/random-number-generator.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698