Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(830)

Unified Diff: pkg/analyzer/lib/src/fasta/ast_builder.dart

Issue 2982033002: Rename FunctionDeclaration to LocalFunctionDeclaration. (Closed)
Patch Set: Documentation tweak. Created 3 years, 5 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « no previous file | pkg/analyzer/test/generated/parser_fasta_listener.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: pkg/analyzer/lib/src/fasta/ast_builder.dart
diff --git a/pkg/analyzer/lib/src/fasta/ast_builder.dart b/pkg/analyzer/lib/src/fasta/ast_builder.dart
index 1c08bf99cdb110e59ba461e898def6c12bf50aed..f0eb16796c3adf82d16dc8d310ee92171e657558 100644
--- a/pkg/analyzer/lib/src/fasta/ast_builder.dart
+++ b/pkg/analyzer/lib/src/fasta/ast_builder.dart
@@ -1523,8 +1523,8 @@ class AstBuilder extends ScopeListener {
}
@override
- void endFunctionDeclaration(Token endToken) {
- debugEvent("FunctionDeclaration");
+ void endLocalFunctionDeclaration(Token token) {
+ debugEvent("LocalFunctionDeclaration");
FunctionBody body = pop();
pop(); // constructor initializers
pop(); // separator before constructor initializers
« no previous file with comments | « no previous file | pkg/analyzer/test/generated/parser_fasta_listener.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698