Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(193)

Unified Diff: runtime/vm/object_arm_test.cc

Issue 297163012: Rename ShifterOperand to Operand on ARM. (Closed) Base URL: http://dart.googlecode.com/svn/branches/bleeding_edge/dart/
Patch Set: Created 6 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « runtime/vm/intrinsifier_arm.cc ('k') | runtime/vm/stub_code_arm.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: runtime/vm/object_arm_test.cc
===================================================================
--- runtime/vm/object_arm_test.cc (revision 36715)
+++ runtime/vm/object_arm_test.cc (working copy)
@@ -21,12 +21,12 @@
__ LoadImmediate(R0, 0);
__ Push(R0);
__ ldr(IP, Address(SP, 0));
- __ add(IP, IP, ShifterOperand(1));
+ __ add(IP, IP, Operand(1));
__ str(IP, Address(SP, 0));
__ ldr(IP, Address(SP, 0));
- __ add(IP, IP, ShifterOperand(1));
+ __ add(IP, IP, Operand(1));
__ Pop(R0);
- __ mov(R0, ShifterOperand(IP));
+ __ mov(R0, Operand(IP));
__ Ret();
}
« no previous file with comments | « runtime/vm/intrinsifier_arm.cc ('k') | runtime/vm/stub_code_arm.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698