Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1667)

Unified Diff: pkg/front_end/lib/src/fasta/parser/parser.dart

Issue 2961813002: Rename handleFunctionType to endFunctionType. (Closed)
Patch Set: Created 3 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: pkg/front_end/lib/src/fasta/parser/parser.dart
diff --git a/pkg/front_end/lib/src/fasta/parser/parser.dart b/pkg/front_end/lib/src/fasta/parser/parser.dart
index b8f8b3002edcfd0d61795e36ed6b34e2195113e3..db73c6aa64daaf69b6c362e35da60e00caab4122 100644
--- a/pkg/front_end/lib/src/fasta/parser/parser.dart
+++ b/pkg/front_end/lib/src/fasta/parser/parser.dart
@@ -1245,7 +1245,7 @@ class Parser {
token = token.next;
token = parseTypeVariablesOpt(token);
token = parseFormalParameters(token, MemberKind.GeneralizedFunctionType);
- listener.handleFunctionType(functionToken, token);
+ listener.endFunctionType(functionToken, token);
return token;
}
« no previous file with comments | « pkg/front_end/lib/src/fasta/parser/listener.dart ('k') | pkg/front_end/lib/src/fasta/source/diet_listener.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698