Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(60)

Unified Diff: components/viz/frame_sinks/mojo_frame_sink_manager.h

Issue 2908783002: WIP Hittest Component.
Patch Set: change HitTestFlags to constants so we can mix and match and convert to struct naming convention Created 3 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: components/viz/frame_sinks/mojo_frame_sink_manager.h
diff --git a/components/viz/frame_sinks/mojo_frame_sink_manager.h b/components/viz/frame_sinks/mojo_frame_sink_manager.h
index 26c0e0c870a7e6495c39ce07d88ae2242e183f58..7eb674c435d44f10fd78538b9c8ce751bcf97187 100644
--- a/components/viz/frame_sinks/mojo_frame_sink_manager.h
+++ b/components/viz/frame_sinks/mojo_frame_sink_manager.h
@@ -87,6 +87,7 @@ class VIZ_EXPORT MojoFrameSinkManager
void OnSurfaceDestroyed(const cc::SurfaceId& surface_id) override;
void OnSurfaceDamageExpected(const cc::SurfaceId& surface_id,
const cc::BeginFrameArgs& args) override;
+ void OnSurfaceWillDraw(const cc::SurfaceId& surface_id) override {}
// GpuCompositorFrameSinkDelegate implementation.
void OnClientConnectionLost(const cc::FrameSinkId& frame_sink_id,

Powered by Google App Engine
This is Rietveld 408576698