Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(386)

Unified Diff: components/viz/frame_sinks/gpu_root_compositor_frame_sink.h

Issue 2908783002: WIP Hittest Component.
Patch Set: change HitTestFlags to constants so we can mix and match and convert to struct naming convention Created 3 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: components/viz/frame_sinks/gpu_root_compositor_frame_sink.h
diff --git a/components/viz/frame_sinks/gpu_root_compositor_frame_sink.h b/components/viz/frame_sinks/gpu_root_compositor_frame_sink.h
index 18df306f331cde0a18d9b0da4444d9d464d1aa3f..c4cdf994012b1b749f89da137d68c2e9d647714a 100644
--- a/components/viz/frame_sinks/gpu_root_compositor_frame_sink.h
+++ b/components/viz/frame_sinks/gpu_root_compositor_frame_sink.h
@@ -12,6 +12,7 @@
#include "cc/surfaces/local_surface_id.h"
#include "cc/surfaces/surface_id.h"
#include "components/viz/frame_sinks/gpu_compositor_frame_sink_delegate.h"
+#include "components/viz/hit_test/hit_test_aggregator.h"
#include "mojo/public/cpp/bindings/associated_binding.h"
#include "mojo/public/cpp/bindings/binding.h"
@@ -102,6 +103,8 @@ class GpuRootCompositorFrameSink
compositor_frame_sink_private_binding_;
mojo::AssociatedBinding<cc::mojom::DisplayPrivate> display_private_binding_;
+ std::unique_ptr<hit_test::HitTestAggregator> hit_test_aggregator_;
+
DISALLOW_COPY_AND_ASSIGN(GpuRootCompositorFrameSink);
};

Powered by Google App Engine
This is Rietveld 408576698