Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(131)

Unified Diff: third_party/WebKit/Source/core/clipboard/DataTransferItem.idl

Issue 2896183002: Rename StringCallback to FunctionStringCallback. (Closed)
Patch Set: Created 3 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/clipboard/DataTransferItem.idl
diff --git a/third_party/WebKit/Source/core/clipboard/DataTransferItem.idl b/third_party/WebKit/Source/core/clipboard/DataTransferItem.idl
index b80843f42991d55ec757ea8fb5f6ace46301e486..d7f3665eec5b77283714c34a9779e0ce616d8d54 100644
--- a/third_party/WebKit/Source/core/clipboard/DataTransferItem.idl
+++ b/third_party/WebKit/Source/core/clipboard/DataTransferItem.idl
@@ -33,7 +33,6 @@
interface DataTransferItem {
readonly attribute DOMString kind;
readonly attribute DOMString type;
- // TODO(foolip): The callback argument should be a FunctionStringCallback.
- [CallWith=ScriptState] void getAsString(StringCallback? callback);
+ [CallWith=ScriptState] void getAsString(FunctionStringCallback? callback);
File? getAsFile();
-};
+};
« no previous file with comments | « third_party/WebKit/Source/core/clipboard/DataTransferItem.cpp ('k') | third_party/WebKit/Source/core/core_idl_files.gni » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698