Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(333)

Unified Diff: third_party/WebKit/Source/core/clipboard/DataTransferItem.h

Issue 2896183002: Rename StringCallback to FunctionStringCallback. (Closed)
Patch Set: Created 3 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « no previous file | third_party/WebKit/Source/core/clipboard/DataTransferItem.cpp » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: third_party/WebKit/Source/core/clipboard/DataTransferItem.h
diff --git a/third_party/WebKit/Source/core/clipboard/DataTransferItem.h b/third_party/WebKit/Source/core/clipboard/DataTransferItem.h
index 14f3b00d65ef9e5871874f5980851755d557ea5e..47fd50305e016c565375a2600ba935312b47639f 100644
--- a/third_party/WebKit/Source/core/clipboard/DataTransferItem.h
+++ b/third_party/WebKit/Source/core/clipboard/DataTransferItem.h
@@ -41,8 +41,8 @@ namespace blink {
class DataObjectItem;
class DataTransfer;
class File;
+class FunctionStringCallback;
class ScriptState;
-class StringCallback;
class CORE_EXPORT DataTransferItem final
: public GarbageCollected<DataTransferItem>,
@@ -56,7 +56,7 @@ class CORE_EXPORT DataTransferItem final
String kind() const;
String type() const;
- void getAsString(ScriptState*, StringCallback*) const;
+ void getAsString(ScriptState*, FunctionStringCallback*) const;
File* getAsFile() const;
DataTransfer* GetDataTransfer() { return data_transfer_.Get(); }
« no previous file with comments | « no previous file | third_party/WebKit/Source/core/clipboard/DataTransferItem.cpp » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698