Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(866)

Unified Diff: third_party/WebKit/Source/platform/scheduler/renderer/renderer_scheduler_impl.h

Issue 2890173002: EQT: Record the max queueing time from navigation start to navigation away (Closed)
Patch Set: flush hist in OnCommitProvitionalLoad Created 3 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/platform/scheduler/renderer/renderer_scheduler_impl.h
diff --git a/third_party/WebKit/Source/platform/scheduler/renderer/renderer_scheduler_impl.h b/third_party/WebKit/Source/platform/scheduler/renderer/renderer_scheduler_impl.h
index 06d370b91b3b4bd20329df0e27299ddaada5815a..a899b9be5d1d0e68c98f871739c651d22cb3a739 100644
--- a/third_party/WebKit/Source/platform/scheduler/renderer/renderer_scheduler_impl.h
+++ b/third_party/WebKit/Source/platform/scheduler/renderer/renderer_scheduler_impl.h
@@ -9,6 +9,7 @@
#include "base/gtest_prod_util.h"
#include "base/macros.h"
#include "base/message_loop/message_loop.h"
+#include "base/metrics/single_sample_metrics.h"
#include "base/single_thread_task_runner.h"
#include "base/synchronization/lock.h"
#include "base/trace_event/trace_log.h"
@@ -108,6 +109,7 @@ class PLATFORM_EXPORT RendererSchedulerImpl
void AddPendingNavigation(NavigatingFrameType type) override;
void RemovePendingNavigation(NavigatingFrameType type) override;
void OnNavigationStarted() override;
+ void OnCommitProvisionalLoad() override;
bool IsHighPriorityWorkAnticipated() override;
bool ShouldYieldForHighPriorityWork() override;
bool CanExceedIdleDeadlineIfRequired() const override;
@@ -374,6 +376,8 @@ class PLATFORM_EXPORT RendererSchedulerImpl
base::TimeTicks now,
base::TimeDelta* expected_use_case_duration) const;
+ std::unique_ptr<base::SingleSampleMetric> GetMaxQueueingTimeHistogram();
+
// An input event of some sort happened, the policy may need updating.
void UpdateForInputEventOnCompositorThread(WebInputEvent::Type type,
InputEventState input_event_state);
@@ -492,6 +496,9 @@ class PLATFORM_EXPORT RendererSchedulerImpl
bool in_idle_period_for_testing;
bool use_virtual_time;
bool is_audio_playing;
+ bool has_navigated;
+ std::unique_ptr<base::SingleSampleMetric> max_queueing_time_histogram;
Liquan (Max) Gu 2017/05/25 16:34:40 Is it better to call max_queueing_time_metric inst
tdresser 2017/05/25 19:43:38 Yup, I agree that's a better name.
Liquan (Max) Gu 2017/05/29 23:44:10 Done.
+ base::TimeDelta max_queueing_time;
std::set<WebViewSchedulerImpl*> web_view_schedulers; // Not owned.
RAILModeObserver* rail_mode_observer; // Not owned.
WakeUpBudgetPool* wake_up_budget_pool; // Not owned.

Powered by Google App Engine
This is Rietveld 408576698