Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(245)

Unified Diff: device/wake_lock/wake_lock_service_impl.cc

Issue 2883903002: Add service unittest for WakeLockServiceImpl. (Closed)
Patch Set: Rename Fake* to *ForTesting Created 3 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « device/wake_lock/wake_lock_service_impl.h ('k') | device/wake_lock/wake_lock_service_impl_for_testing.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: device/wake_lock/wake_lock_service_impl.cc
diff --git a/device/wake_lock/wake_lock_service_impl.cc b/device/wake_lock/wake_lock_service_impl.cc
index 7031f7846abcd260614d96fee52dc803d551f1f4..86ce13be972da207d4ccd9d955408be92aa6203f 100644
--- a/device/wake_lock/wake_lock_service_impl.cc
+++ b/device/wake_lock/wake_lock_service_impl.cc
@@ -53,10 +53,10 @@ WakeLockServiceImpl::WakeLockServiceImpl(
int context_id,
WakeLockContextCallback native_view_getter,
scoped_refptr<base::SingleThreadTaskRunner> file_task_runner)
- : type_(type),
+ : num_lock_requests_(0),
+ type_(type),
reason_(reason),
description_(base::MakeUnique<std::string>(description)),
- num_lock_requests_(0),
#if defined(OS_ANDROID)
context_id_(context_id),
native_view_getter_(native_view_getter),
« no previous file with comments | « device/wake_lock/wake_lock_service_impl.h ('k') | device/wake_lock/wake_lock_service_impl_for_testing.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698