Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(735)

Unified Diff: third_party/WebKit/Source/modules/accessibility/AXObjectImpl.h

Issue 2863703003: A11y: Rename AXSupportedAction to AXDefaultActionVerb. (Closed)
Patch Set: Rebase. Created 3 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/modules/accessibility/AXObjectImpl.h
diff --git a/third_party/WebKit/Source/modules/accessibility/AXObjectImpl.h b/third_party/WebKit/Source/modules/accessibility/AXObjectImpl.h
index 789a85ce4b4eded5220e020bbcd891507b959316..205cc1ea05925ef025574448a43cfaef89c329bd 100644
--- a/third_party/WebKit/Source/modules/accessibility/AXObjectImpl.h
+++ b/third_party/WebKit/Source/modules/accessibility/AXObjectImpl.h
@@ -251,7 +251,7 @@ enum AXObjectInclusion {
kDefaultBehavior,
};
-enum class AXSupportedAction {
+enum class AXDefaultActionVerb {
kNone = 0,
kActivate,
kCheck,
@@ -862,7 +862,7 @@ class MODULES_EXPORT AXObjectImpl
virtual void GetWordBoundaries(Vector<AXRange>&) const {}
// Properties of interactive elements.
- AXSupportedAction Action() const;
+ AXDefaultActionVerb Action() const;
AccessibilityButtonState CheckedState() const;
virtual AriaCurrentState GetAriaCurrentState() const {
return kAriaCurrentStateUndefined;

Powered by Google App Engine
This is Rietveld 408576698