Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(106)

Unified Diff: src/counters.h

Issue 2856663002: Don't report array buffer allocations less than 1 Mb. (Closed)
Patch Set: Created 3 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « no previous file | src/objects.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/counters.h
diff --git a/src/counters.h b/src/counters.h
index 79fd2359a783e49f503e7e11193329b6ea2b8eb6..4094e001fcd550e8ff170e96440472b0edf6fb6d 100644
--- a/src/counters.h
+++ b/src/counters.h
@@ -935,7 +935,7 @@ class RuntimeCallTimerScope {
51) \
HR(wasm_functions_per_wasm_module, V8.WasmFunctionsPerModule.wasm, 1, \
100000, 51) \
- HR(array_buffer_big_allocations, V8.ArrayBufferBigAllocations, 0, 4096, 13) \
+ HR(array_buffer_big_allocations, V8.ArrayBufferBigAllocations, 1, 4096, 13) \
Ilya Sherman 2017/05/01 19:51:14 Please rename the histogram, as you are changing t
kschimpf 2017/05/04 20:51:36 Is this really necessary. This metric was created
Ilya Sherman 2017/05/04 21:21:21 Well, I think it might actually be the same bucket
kschimpf 2017/05/05 17:05:37 Ok. Changing the name of the metric, and introduci
HR(array_buffer_new_size_failures, V8.ArrayBufferNewSizeFailures, 0, 4096, 13)
#define HISTOGRAM_TIMER_LIST(HT) \
« no previous file with comments | « no previous file | src/objects.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698