Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(371)

Unified Diff: components/security_interstitials/core/browser/resources/interstitial_v2.js

Issue 2852333003: Rename SafeBrowsingErrorUI to SafeBrowsingLoudErrorUI (Closed)
Patch Set: Move SafeBrowsingErrorUI to SafeBrowsingLoudErrorUI Created 3 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: components/security_interstitials/core/browser/resources/interstitial_v2.js
diff --git a/components/security_interstitials/core/browser/resources/interstitial_v2.js b/components/security_interstitials/core/browser/resources/interstitial_v2.js
index 4fa48eac865d91d45a46eb37c794bca79e03efa5..7fe6ac69adb52d826b13a3e4fc214512044f135c 100644
--- a/components/security_interstitials/core/browser/resources/interstitial_v2.js
+++ b/components/security_interstitials/core/browser/resources/interstitial_v2.js
@@ -102,7 +102,8 @@ function setupEvents() {
var ssl = interstitialType == 'SSL';
var captivePortal = interstitialType == 'CAPTIVE_PORTAL';
var badClock = ssl && loadTimeData.getBoolean('bad_clock');
- var hidePrimaryButton = badClock && loadTimeData.getBoolean(
+ var webView = loadTimeData.getBoolean('webview');
+ var hidePrimaryButton = (badClock || webView) && loadTimeData.getBoolean(
'hide_primary_button');
felt 2017/05/03 18:17:01 I don't think we need this webView variable. We sh
if (ssl) {

Powered by Google App Engine
This is Rietveld 408576698