Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(194)

Unified Diff: third_party/WebKit/Source/core/dom/PendingScript.h

Issue 2815163005: Rename PendingScript::Url() to UrlForClassicScript() (Closed)
Patch Set: Created 3 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/dom/PendingScript.h
diff --git a/third_party/WebKit/Source/core/dom/PendingScript.h b/third_party/WebKit/Source/core/dom/PendingScript.h
index f0175f57aeea061e7b97d907e1708ec19620e2eb..6886b9bb7e73abb0718a40f719ea46defc7d726c 100644
--- a/third_party/WebKit/Source/core/dom/PendingScript.h
+++ b/third_party/WebKit/Source/core/dom/PendingScript.h
@@ -88,14 +88,14 @@ class CORE_EXPORT PendingScript
// https://html.spec.whatwg.org/#the-script-is-ready
virtual bool IsReady() const = 0;
- virtual KURL Url() const = 0;
virtual bool IsExternal() const = 0;
virtual bool ErrorOccurred() const = 0;
virtual bool WasCanceled() const = 0;
virtual void StartStreamingIfPossible(Document*, ScriptStreamer::Type) = 0;
- // Used for document.write() intervention.
- // Has effects only for classic scripts.
+ // The following two methods are used for document.write() intervention and
+ // have effects only for classic scripts.
+ virtual KURL UrlForClassicScript() const = 0;
virtual void RemoveFromMemoryCache() = 0;
void Dispose();

Powered by Google App Engine
This is Rietveld 408576698