Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(86)

Side by Side Diff: third_party/WebKit/Source/core/editing/FrameSelection.h

Issue 2803583002: Rename PendingSelection to LayoutSelection (Closed)
Patch Set: Created 3 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
OLDNEW
1 /* 1 /*
2 * Copyright (C) 2004, 2005, 2006, 2007, 2008, 2009, 2010 Apple Inc. All rights 2 * Copyright (C) 2004, 2005, 2006, 2007, 2008, 2009, 2010 Apple Inc. All rights
3 * reserved. 3 * reserved.
4 * 4 *
5 * Redistribution and use in source and binary forms, with or without 5 * Redistribution and use in source and binary forms, with or without
6 * modification, are permitted provided that the following conditions 6 * modification, are permitted provided that the following conditions
7 * are met: 7 * are met:
8 * 1. Redistributions of source code must retain the above copyright 8 * 1. Redistributions of source code must retain the above copyright
9 * notice, this list of conditions and the following disclaimer. 9 * notice, this list of conditions and the following disclaimer.
10 * 2. Redistributions in binary form must reproduce the above copyright 10 * 2. Redistributions in binary form must reproduce the above copyright
(...skipping 35 matching lines...) Expand 10 before | Expand all | Expand 10 after
46 namespace blink { 46 namespace blink {
47 47
48 class DisplayItemClient; 48 class DisplayItemClient;
49 class LayoutBlock; 49 class LayoutBlock;
50 class LocalFrame; 50 class LocalFrame;
51 class FrameCaret; 51 class FrameCaret;
52 class GranularityStrategy; 52 class GranularityStrategy;
53 class GraphicsContext; 53 class GraphicsContext;
54 class HTMLFormElement; 54 class HTMLFormElement;
55 class SelectionEditor; 55 class SelectionEditor;
56 class PendingSelection; 56 class LayoutSelection;
57 class TextIteratorBehavior; 57 class TextIteratorBehavior;
58 struct PaintInvalidatorContext; 58 struct PaintInvalidatorContext;
59 59
60 enum class CursorAlignOnScroll { IfNeeded, Always }; 60 enum class CursorAlignOnScroll { IfNeeded, Always };
61 61
62 enum EUserTriggered { NotUserTriggered = 0, UserTriggered = 1 }; 62 enum EUserTriggered { NotUserTriggered = 0, UserTriggered = 1 };
63 63
64 enum RevealExtentOption { RevealExtent, DoNotRevealExtent }; 64 enum RevealExtentOption { RevealExtent, DoNotRevealExtent };
65 65
66 enum class SelectionDirectionalMode { NonDirectional, Directional }; 66 enum class SelectionDirectionalMode { NonDirectional, Directional };
(...skipping 217 matching lines...) Expand 10 before | Expand all | Expand 10 after
284 const Position& end); 284 const Position& end);
285 285
286 GranularityStrategy* granularityStrategy(); 286 GranularityStrategy* granularityStrategy();
287 287
288 // Implementation of |SynchronousMutationObserver| member functions. 288 // Implementation of |SynchronousMutationObserver| member functions.
289 void contextDestroyed(Document*) final; 289 void contextDestroyed(Document*) final;
290 void nodeChildrenWillBeRemoved(ContainerNode&) final; 290 void nodeChildrenWillBeRemoved(ContainerNode&) final;
291 void nodeWillBeRemoved(Node&) final; 291 void nodeWillBeRemoved(Node&) final;
292 292
293 Member<LocalFrame> m_frame; 293 Member<LocalFrame> m_frame;
294 const Member<PendingSelection> m_pendingSelection; 294 const Member<LayoutSelection> m_pendingSelection;
yosin_UTC9 2017/04/06 04:21:48 I expect following patch will rename |m_pendingSel
295 const Member<SelectionEditor> m_selectionEditor; 295 const Member<SelectionEditor> m_selectionEditor;
296 296
297 TextGranularity m_granularity; 297 TextGranularity m_granularity;
298 LayoutUnit m_xPosForVerticalArrowNavigation; 298 LayoutUnit m_xPosForVerticalArrowNavigation;
299 299
300 bool m_focused : 1; 300 bool m_focused : 1;
301 301
302 // Controls text granularity used to adjust the selection's extent in 302 // Controls text granularity used to adjust the selection's extent in
303 // moveRangeSelectionExtent. 303 // moveRangeSelectionExtent.
304 std::unique_ptr<GranularityStrategy> m_granularityStrategy; 304 std::unique_ptr<GranularityStrategy> m_granularityStrategy;
305 305
306 const Member<FrameCaret> m_frameCaret; 306 const Member<FrameCaret> m_frameCaret;
307 bool m_useSecureKeyboardEntryWhenActive = false; 307 bool m_useSecureKeyboardEntryWhenActive = false;
308 }; 308 };
309 309
310 } // namespace blink 310 } // namespace blink
311 311
312 #ifndef NDEBUG 312 #ifndef NDEBUG
313 // Outside the WebCore namespace for ease of invocation from gdb. 313 // Outside the WebCore namespace for ease of invocation from gdb.
314 void showTree(const blink::FrameSelection&); 314 void showTree(const blink::FrameSelection&);
315 void showTree(const blink::FrameSelection*); 315 void showTree(const blink::FrameSelection*);
316 #endif 316 #endif
317 317
318 #endif // FrameSelection_h 318 #endif // FrameSelection_h
OLDNEW
« no previous file with comments | « third_party/WebKit/Source/core/editing/BUILD.gn ('k') | third_party/WebKit/Source/core/editing/FrameSelection.cpp » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698