Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(622)

Unified Diff: third_party/WebKit/Source/core/layout/ng/ng_physical_text_fragment.h

Issue 2797053002: Remove redundant casts, use NGLayoutInputNode base functions everywhere (Closed)
Patch Set: Created 3 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « third_party/WebKit/Source/core/layout/ng/ng_layout_input_node.h ('k') | no next file » | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: third_party/WebKit/Source/core/layout/ng/ng_physical_text_fragment.h
diff --git a/third_party/WebKit/Source/core/layout/ng/ng_physical_text_fragment.h b/third_party/WebKit/Source/core/layout/ng/ng_physical_text_fragment.h
index 451c3f3550db1f98901ea889d8adabb6d25bdb49..63416fbac121ae7ddd5939e20aeef537cd685d85 100644
--- a/third_party/WebKit/Source/core/layout/ng/ng_physical_text_fragment.h
+++ b/third_party/WebKit/Source/core/layout/ng/ng_physical_text_fragment.h
@@ -47,9 +47,9 @@ class CORE_EXPORT NGPhysicalTextFragment final : public NGPhysicalFragment {
DEFINE_TYPE_CASTS(NGPhysicalTextFragment,
NGPhysicalFragment,
- text,
- text->Type() == NGPhysicalFragment::kFragmentText,
- text.Type() == NGPhysicalFragment::kFragmentText);
+ fragment,
+ fragment->IsText(),
+ fragment.IsText());
} // namespace blink
« no previous file with comments | « third_party/WebKit/Source/core/layout/ng/ng_layout_input_node.h ('k') | no next file » | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698