Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(2335)

Unified Diff: third_party/WebKit/Source/core/layout/ng/ng_block_node.h

Issue 2797053002: Remove redundant casts, use NGLayoutInputNode base functions everywhere (Closed)
Patch Set: Created 3 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/layout/ng/ng_block_node.h
diff --git a/third_party/WebKit/Source/core/layout/ng/ng_block_node.h b/third_party/WebKit/Source/core/layout/ng/ng_block_node.h
index 16d95bfa8d85ad46a15760b4e3ea89dd4a5c2b93..c713b9526736c9cbe5421e0961ac47bf60350f31 100644
--- a/third_party/WebKit/Source/core/layout/ng/ng_block_node.h
+++ b/third_party/WebKit/Source/core/layout/ng/ng_block_node.h
@@ -79,8 +79,8 @@ class CORE_EXPORT NGBlockNode final : public NGLayoutInputNode {
DEFINE_TYPE_CASTS(NGBlockNode,
NGLayoutInputNode,
node,
- node->Type() == NGLayoutInputNode::kLegacyBlock,
- node.Type() == NGLayoutInputNode::kLegacyBlock);
+ node->IsBlock(),
+ node.IsBlock());
} // namespace blink

Powered by Google App Engine
This is Rietveld 408576698