Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(456)

Unified Diff: components/signin/public/interfaces/account_id_traits.h

Issue 2753753007: Introduce Identity Service and its initial usage (Closed)
Patch Set: Self-review Created 3 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: components/signin/public/interfaces/account_id_traits.h
diff --git a/components/signin/public/interfaces/account_id_traits.h b/components/signin/public/interfaces/account_id_traits.h
index cc1d39de91773289c8fe34eaeb1a56d05b334390..a2107cbb30ba76df453df58e7313a8f1f023478b 100644
--- a/components/signin/public/interfaces/account_id_traits.h
+++ b/components/signin/public/interfaces/account_id_traits.h
@@ -100,6 +100,10 @@ struct StructTraits<signin::mojom::AccountIdDataView, AccountId> {
return out->is_valid();
}
+
+ static bool IsNull(const AccountId& input) { return !input.is_valid(); }
msarda 2017/03/23 10:48:57 I suppose these are standard naming conventions fo
blundell 2017/03/24 09:37:59 Yes. They're what allow a typemapped type to be de
+
+ static void SetToNull(AccountId* output) { *output = EmptyAccountId(); }
};
} // namespace mojo

Powered by Google App Engine
This is Rietveld 408576698