Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(982)

Unified Diff: third_party/WebKit/Source/core/editing/FrameSelection.cpp

Issue 2723993002: Rename platform/Widget to platform/FrameViewBase in core. (Closed)
Patch Set: Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « third_party/WebKit/Source/core/dom/Document.cpp ('k') | third_party/WebKit/Source/core/frame/FrameView.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: third_party/WebKit/Source/core/editing/FrameSelection.cpp
diff --git a/third_party/WebKit/Source/core/editing/FrameSelection.cpp b/third_party/WebKit/Source/core/editing/FrameSelection.cpp
index 6ab0026eb81798ca50b923e27375475c361ed7a0..9247096b66c092cb4808ae1119c89ba1335a6e66 100644
--- a/third_party/WebKit/Source/core/editing/FrameSelection.cpp
+++ b/third_party/WebKit/Source/core/editing/FrameSelection.cpp
@@ -842,8 +842,8 @@ static bool isFrameElement(const Node* n) {
LayoutObject* layoutObject = n->layoutObject();
if (!layoutObject || !layoutObject->isLayoutPart())
return false;
- Widget* widget = toLayoutPart(layoutObject)->widget();
- return widget && widget->isFrameView();
+ FrameViewBase* frameViewBase = toLayoutPart(layoutObject)->widget();
+ return frameViewBase && frameViewBase->isFrameView();
}
void FrameSelection::setFocusedNodeIfNeeded() {
« no previous file with comments | « third_party/WebKit/Source/core/dom/Document.cpp ('k') | third_party/WebKit/Source/core/frame/FrameView.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698