Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(289)

Unified Diff: content/browser/cache_storage/cache_storage_dispatcher_host.cc

Issue 2716583003: Rename Origin.unique() to opaque().
Patch Set: Update new uses post-rebase Created 3 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: content/browser/cache_storage/cache_storage_dispatcher_host.cc
diff --git a/content/browser/cache_storage/cache_storage_dispatcher_host.cc b/content/browser/cache_storage/cache_storage_dispatcher_host.cc
index c3bb6db5ceb69b59831b91053937453a46ad2a69..981c20b87480146a7eb46687dbca22459a29eb7d 100644
--- a/content/browser/cache_storage/cache_storage_dispatcher_host.cc
+++ b/content/browser/cache_storage/cache_storage_dispatcher_host.cc
@@ -61,7 +61,7 @@ blink::WebServiceWorkerCacheError ToWebServiceWorkerCacheError(
}
bool OriginCanAccessCacheStorage(const url::Origin& origin) {
- return !origin.unique() && IsOriginSecure(origin.GetURL());
+ return !origin.opaque() && IsOriginSecure(origin.GetURL());
}
void StopPreservingCache(
« no previous file with comments | « content/browser/browsing_data/clear_site_data_throttle.cc ('k') | content/browser/child_process_security_policy_impl.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698