Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(67)

Unified Diff: third_party/WebKit/Source/web/WebFrameImplBase.h

Issue 2714943004: Move unique name generation and tracking into //content. (Closed)
Patch Set: . Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/web/WebFrameImplBase.h
diff --git a/third_party/WebKit/Source/web/WebFrameImplBase.h b/third_party/WebKit/Source/web/WebFrameImplBase.h
index 0e6b304df4af78b3fe922e2310bb7baa709986a5..9b5367c5772e99afffb85eac4e3bf66b5ab266b2 100644
--- a/third_party/WebKit/Source/web/WebFrameImplBase.h
+++ b/third_party/WebKit/Source/web/WebFrameImplBase.h
@@ -35,8 +35,7 @@ class WEB_EXPORT WebFrameImplBase
virtual void initializeCoreFrame(FrameHost*,
FrameOwner*,
- const AtomicString& name,
- const AtomicString& uniqueName) = 0;
+ const AtomicString& name) = 0;
// TODO(dcheng): Rename this to coreFrame()? This probably also shouldn't be
// const...
virtual Frame* frame() const = 0;

Powered by Google App Engine
This is Rietveld 408576698