Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(167)

Unified Diff: third_party/WebKit/Source/platform/loader/fetch/ResourceFetcher.cpp

Issue 2714423002: Rename SkipServiceWorker to ServiceWorkerMode (Closed)
Patch Set: typos-- Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/platform/loader/fetch/ResourceFetcher.cpp
diff --git a/third_party/WebKit/Source/platform/loader/fetch/ResourceFetcher.cpp b/third_party/WebKit/Source/platform/loader/fetch/ResourceFetcher.cpp
index eae214e92b1288628071bde41d65695a8a8e2fda..65ce985e3d50d1b1e5f5a7fd675744844ef7589f 100644
--- a/third_party/WebKit/Source/platform/loader/fetch/ResourceFetcher.cpp
+++ b/third_party/WebKit/Source/platform/loader/fetch/ResourceFetcher.cpp
@@ -1258,7 +1258,7 @@ bool ResourceFetcher::startLoad(Resource* resource) {
// https://w3c.github.io/webappsec-suborigins/.
SecurityOrigin* sourceOrigin = context().getSecurityOrigin();
if (sourceOrigin && sourceOrigin->hasSuborigin())
- request.setSkipServiceWorker(WebURLRequest::SkipServiceWorker::All);
+ request.setServiceWorkerMode(WebURLRequest::ServiceWorkerMode::None);
ResourceLoader* loader = ResourceLoader::create(this, resource);
if (resource->shouldBlockLoadEvent())

Powered by Google App Engine
This is Rietveld 408576698