Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(84)

Unified Diff: content/common/resource_request.h

Issue 2714423002: Rename SkipServiceWorker to ServiceWorkerMode (Closed)
Patch Set: typos-- Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « content/common/resource_messages.h ('k') | content/common/service_worker/service_worker_types.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: content/common/resource_request.h
diff --git a/content/common/resource_request.h b/content/common/resource_request.h
index 278566ce853daafd36349c1fbf9f03cafc65c514..2cf0ee50a2b55e40df279530b9d017fc397ee8d8 100644
--- a/content/common/resource_request.h
+++ b/content/common/resource_request.h
@@ -102,8 +102,9 @@ struct CONTENT_EXPORT ResourceRequest {
// fetch() in the Service Worker script.
bool originated_from_service_worker = false;
- // Indicates which types of ServiceWorkers should skip handling this request.
- SkipServiceWorker skip_service_worker = SkipServiceWorker::NONE;
+ // The service worker mode that indicates which service workers should get
+ // events for this request.
+ ServiceWorkerMode service_worker_mode = ServiceWorkerMode::ALL;
// The request mode passed to the ServiceWorker.
FetchRequestMode fetch_request_mode = FETCH_REQUEST_MODE_SAME_ORIGIN;
« no previous file with comments | « content/common/resource_messages.h ('k') | content/common/service_worker/service_worker_types.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698