Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(537)

Unified Diff: third_party/WebKit/Source/core/loader/DocumentLoader.h

Issue 2712033002: Part 1 Of Renaming FrameLoaderClient to LocalFrameClient. (Closed)
Patch Set: Change all forward declarations of FrameLoaderClient to LocalFrameClient and fix call sites. Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/loader/DocumentLoader.h
diff --git a/third_party/WebKit/Source/core/loader/DocumentLoader.h b/third_party/WebKit/Source/core/loader/DocumentLoader.h
index 2c129530097bb57828b93d17062acf3630deb5e8..ac5e7b73550fd341e906f5e24fdf942fbc32e069 100644
--- a/third_party/WebKit/Source/core/loader/DocumentLoader.h
+++ b/third_party/WebKit/Source/core/loader/DocumentLoader.h
@@ -51,6 +51,7 @@
#include "public/platform/WebLoadingBehaviorFlag.h"
#include "wtf/HashSet.h"
#include "wtf/RefPtr.h"
+
#include <memory>
namespace blink {
@@ -59,8 +60,8 @@ class ApplicationCacheHost;
class ResourceFetcher;
class DocumentInit;
class LocalFrame;
+class LocalFrameClient;
class FrameLoader;
-class FrameLoaderClient;
class ResourceTimingInfo;
class WebDocumentSubresourceFilter;
struct ViewportDescriptionWrapper;
@@ -207,7 +208,7 @@ class CORE_EXPORT DocumentLoader
// Use these method only where it's guaranteed that |m_frame| hasn't been
// cleared.
FrameLoader& frameLoader() const;
- FrameLoaderClient& frameLoaderClient() const;
+ LocalFrameClient& localFrameClient() const;
dcheng 2017/02/24 05:30:21 Minor naming nit: "local" is implied by "Document"
void commitIfReady();
void commitData(const char* bytes, size_t length);

Powered by Google App Engine
This is Rietveld 408576698