Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(591)

Unified Diff: services/ui/ws/frame_generator.h

Issue 2708153005: Rename SurfaceIdAllocator to LocalSurfaceIdAllocator (Closed)
Patch Set: Delete useless include Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: services/ui/ws/frame_generator.h
diff --git a/services/ui/ws/frame_generator.h b/services/ui/ws/frame_generator.h
index bfad392a9902e872b256055f3016ee00c0af9cb5..19b4348e412e069a095673962fd078755a51a85e 100644
--- a/services/ui/ws/frame_generator.h
+++ b/services/ui/ws/frame_generator.h
@@ -11,8 +11,8 @@
#include "base/timer/timer.h"
#include "cc/ipc/display_compositor.mojom.h"
#include "cc/surfaces/frame_sink_id.h"
+#include "cc/surfaces/local_surface_id_allocator.h"
#include "cc/surfaces/surface_id.h"
-#include "cc/surfaces/surface_id_allocator.h"
#include "cc/surfaces/surface_reference.h"
#include "services/ui/public/interfaces/window_tree_constants.mojom.h"
#include "services/ui/ws/ids.h"
@@ -75,7 +75,7 @@ class FrameGenerator : public cc::mojom::MojoCompositorFrameSinkClient {
gfx::Size last_submitted_frame_size_;
cc::LocalSurfaceId local_surface_id_;
- cc::SurfaceIdAllocator id_allocator_;
+ cc::LocalSurfaceIdAllocator id_allocator_;
cc::mojom::MojoCompositorFrameSinkAssociatedPtr compositor_frame_sink_;
cc::mojom::DisplayPrivateAssociatedPtr display_private_;

Powered by Google App Engine
This is Rietveld 408576698