Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(2076)

Unified Diff: content/renderer/android/synchronous_compositor_frame_sink.h

Issue 2708153005: Rename SurfaceIdAllocator to LocalSurfaceIdAllocator (Closed)
Patch Set: Delete useless include Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: content/renderer/android/synchronous_compositor_frame_sink.h
diff --git a/content/renderer/android/synchronous_compositor_frame_sink.h b/content/renderer/android/synchronous_compositor_frame_sink.h
index 771a73c2d60e1e727d7646e8ba05ec2a464f6cb4..e35a892eee3230ac3d610c2b1e51d8a6a257ae7f 100644
--- a/content/renderer/android/synchronous_compositor_frame_sink.h
+++ b/content/renderer/android/synchronous_compositor_frame_sink.h
@@ -30,7 +30,7 @@ class BeginFrameSource;
class CompositorFrameSinkSupport;
class ContextProvider;
class Display;
-class SurfaceIdAllocator;
+class LocalSurfaceIdAllocator;
class SurfaceManager;
}
@@ -151,7 +151,7 @@ class SynchronousCompositorFrameSink
// TODO(danakj): These don't to be stored in unique_ptrs when OutputSurface
// is owned/destroyed on the compositor thread.
std::unique_ptr<cc::SurfaceManager> surface_manager_;
- std::unique_ptr<cc::SurfaceIdAllocator> surface_id_allocator_;
+ std::unique_ptr<cc::LocalSurfaceIdAllocator> local_surface_id_allocator_;
cc::LocalSurfaceId child_local_surface_id_;
cc::LocalSurfaceId root_local_surface_id_;
// Uses surface_manager_.

Powered by Google App Engine
This is Rietveld 408576698