Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(2080)

Unified Diff: android_webview/browser/hardware_renderer.h

Issue 2708153005: Rename SurfaceIdAllocator to LocalSurfaceIdAllocator (Closed)
Patch Set: Delete useless include Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « no previous file | android_webview/browser/hardware_renderer.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: android_webview/browser/hardware_renderer.h
diff --git a/android_webview/browser/hardware_renderer.h b/android_webview/browser/hardware_renderer.h
index 2ac15392eee4bbfedf3cd78004dcd211ca4954dd..58bd994d7c81d09364af3b87f65271d2c70fa872 100644
--- a/android_webview/browser/hardware_renderer.h
+++ b/android_webview/browser/hardware_renderer.h
@@ -19,7 +19,7 @@ struct AwDrawGLInfo;
namespace cc {
class SurfaceFactory;
-class SurfaceIdAllocator;
+class LocalSurfaceIdAllocator;
}
namespace android_webview {
@@ -81,7 +81,8 @@ class HardwareRenderer : public cc::SurfaceFactoryClient {
const scoped_refptr<SurfacesInstance> surfaces_;
cc::FrameSinkId frame_sink_id_;
- const std::unique_ptr<cc::SurfaceIdAllocator> surface_id_allocator_;
+ const std::unique_ptr<cc::LocalSurfaceIdAllocator>
+ local_surface_id_allocator_;
std::unique_ptr<cc::SurfaceFactory> surface_factory_;
cc::LocalSurfaceId child_id_;
CompositorID compositor_id_;
« no previous file with comments | « no previous file | android_webview/browser/hardware_renderer.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698